Extension, Module

Developer
Supported

Zenbu

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Nicolas Bottari

     

You must be logged in to post.

ee3 - Syntax error or access violation: 1064

Support Request

travisb
travisb

Hi, working on upgrade from ee2 > ee3 and getting the following error when trying to access Zenbu in ee3 (or edit channels):

————
SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘) AND c.site_id = 1 ORDER BY c.cat_order’ at line 4:
SELECT c.*, cg.* FROM exp_categories c LEFT JOIN exp_category_groups cg ON cg.group_id = c.group_id WHERE c.group_id IN (,) AND c.site_id = 1 ORDER BY c.cat_order

ee/legacy/database/drivers/mysqli/mysqli_connection.php:122

Stack Trace: hide details

#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(137): CI_DB_mysqli_connection->query(‘SELECT c.*, cg….’)
#1 ee/legacy/database/DB_driver.php(297): CI_DB_mysqli_driver->_execute(‘SELECT c.*, cg….’)
#2 ee/legacy/database/DB_driver.php(203): CI_DB_driver->simple_query(‘SELECT c.*, cg….’)
#3 user/addons/zenbu/librairies/platform/ee/Categories.php(122): CI_DB_driver->query(‘SELECT c.*, cg….’)
#4 user/addons/zenbu/librairies/platform/ee/Categories.php(37): Zenbu\librairies\platform\ee\Categories->getCategoriesInGroups(Array)
#5 user/addons/zenbu/librairies/Filters.php(25): Zenbu\librairies\platform\ee\Categories->getNestedCategories()
#6 user/addons/zenbu/controllers/ZenbuController.php(42): Zenbu\librairies\Filters->getFirstFilterOptions()
#7 user/addons/zenbu/mcp.zenbu.php(100): Zenbu\controllers\ZenbuController->actionIndex()
#8 [internal function]: Zenbu_mcp->index()
#9 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(1656): call_user_func_array(Array, Array)
#10 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(918): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings(‘zenbu’, ‘index’, Array)
#11 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings(‘zenbu’)
#12 ee/EllisLab/ExpressionEngine/Core/Core.php(189): call_user_func_array(Array, Array)
#13 ee/EllisLab/ExpressionEngine/Core/Core.php(94): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#14 ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#15 public/admin/index.php(143): require_once(’...’)
#15 public/admin/index.php(143): require_once(’...’)
————

Zenbu v 2.2.0 and ee 3.5.10 (local env):  tried module uninstall and reinstall, but same result. Without zenbu am able to access entries successfully.

travisb
# 1
travisb

Nicolas’ response lead to solution: I had a separator (pipe) character by itself in a channel row in exp_channels cat_group column. Removed character and fixed.