Module

Archived
Forum
(read-only)

Charlie Hawker does not actively monitor this forum
(but you can still get help from other EE users).

Weblog Entries Exporter

ExpressionEngine 1.x

Back to this add-on's main page
View Other Add-ons From Charlie Hawker

     

You must be logged in to post.

File not found

Bug Report

VosSavant
VosSavant

Hi there,

Just purchased your module, and when trying to run it for the first time receive a “File not found” page in Firefox, with the following:

Firefox can't find the file at http://www.example.com/system/index.php?S=0&C=modules&M=weblog_entries_exporter&P=download. 

The strange thing is that your module works fine for one weblog, but not the one I need it to work on :)

The site has just two weblogs: pages and products. The products weblog has tens of thousands of entries in it, so I don’t know if the sheer amount of entries or formatting in one of the entries is causing a problem. In either case, I’m not sure where to start. Would you be able to take a look or provide some guidance? Thank you.


Ryan

VosSavant
# 1
VosSavant

If the developer of this product is still around, I would appreciate a response. I paid money for this software, and it isn’t working. Unless I can get a resolution, I will be asking for a refund.

Charlie Hawker
# 2
Developer
Charlie Hawker

Ryan,

Sorry for the slow response - I was away for Christmas. I suspect that the sheer volume of the products may be causing something like PHP’s memory being exhausted or a timeout. How long does it run for before telling you the file’s not found? Do you have access to your server’s error logs?

Cheers,
Charlie

VosSavant
# 3
VosSavant

Hey Charlie,

Now I feel like a jerk… :(

The message appears just a second or two after I click “Go.” I do not have access to the server error logs, unfortunately.

Charlie Hawker
# 4
Developer
Charlie Hawker

Hmmm… ok, so there’s no chance it’s timing out then. I suppose it could still be exhausting PHP’s memory allocation. Could be some other error too. What fieldtypes are assigned to the product weblog? Anything special?

VosSavant
# 5
VosSavant

Hey Charlie,

There are several product fields: price (matrix fieldtype), description (wygwam/wysiwyg), dropdown, and image upload.

Charlie Hawker
# 6
Developer
Charlie Hawker

Aha, is the image upload field an ngen file field or something else? If it’s going old school and physically saving images into the database then that could be the issue. The other fields sound fine.

VosSavant
# 7
VosSavant

There are actually two image upload fields—the first is a regular text input that takes a full image path. The second is actually a Matrix field with an ngen cell type and a textarea cell type.

Charlie Hawker
# 8
Developer
Charlie Hawker

Hmmm, that shouldn’t create issues I don’t think. Do you have access to the mysql database? Could you query it to see how many records there are in the products weblog?

VosSavant
# 9
VosSavant

There are about 56,000 records in that weblog. I’m guessing that the sheer volume of records may be the source of our troubles.

Charlie Hawker
# 10
Developer
Charlie Hawker

Woah! That’s a lot of products! I expect the volume is what’s causing issues yeah. Would it be acceptable to you to have a mechanism to export them in segments (i.e. 1-1000, 1001 - 2000 or something)?

VosSavant
# 11
VosSavant

Yeah, that might work. The client has been importing products afresh this whole time (rather than exporting, then importing), so the ultimate figure is decreasing all the time—would still be several thousands to export.