Extension

Developer
Supported

VL File Generator

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Viget Labs

     

You must be logged in to post.

Files not writing to server

Support Request

zerostyle
zerostyle

I cannot get the files to write, I was hoping you could help me trouble shoot.

Here are my settings for the json file I am trying to write:
http://cl.ly/image/1a0Q3L3p0K0S

Here is my template manager, so you can see the path’s:
http://cl.ly/image/2O3z0M1F0D2M

I have a folder in my main directory named “json” which I have set to 777 to write to it.

I want the json files to be updated when the Site, Images and Home channels get updated. It’s not working at the moment. Any suggestions?

Best,

Joshua

Viget
# 1
Developer
Viget

What version of EE are you on?

zerostyle
# 2
zerostyle

v2.5.2 - Build Date: 20120606

Viget
# 3
Developer
Viget

Is PHP safe_mode turned on on the server? The extension depends on being able to use fopen.

zerostyle
# 4
zerostyle

I can’t figure out where those settings are. I tried to google it and looked in the EE forums, but I turned up nothing. Can you tell me where to look?

Viget
# 5
Developer
Viget

That’s not an EE specific thing; that’s a PHP thing. You should check with your host to figure that out (usually hosts have that kinda stuff in a KB or forum).

zerostyle
# 6
zerostyle

I was able to turn safe_mode on with my server. I am still not seeing the file get created? Any other suggestions.

zerostyle
# 7
zerostyle

Sorry, hold up. I checked my php info, but safe mode is not show up as on yet.

zerostyle
# 8
zerostyle

It’s on now. Here is the php info: http://z-s.co/b

Viget
# 9
Developer
Viget

Sorry, guess I wasn’t clear enough. Safe mode needs to be off. Can you check with your host to see if it allows fopen?

zerostyle
# 10
zerostyle

That was it, thanks!