Extension

Developer
Supported

Textile Editor Helper (TEH)

ExpressionEngine 1.x, ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Mike Kroll

     

You must be logged in to post.

No visible TEH editor

General

Fritzinger
Fritzinger

Please excuse what is probably a very noob question.

I downloaded TEH v2.0.4, and installed it with EE 2.1.3. The extension is enabled and the paths appear to be pointing to the correct places. However I see no rich text editor buttons on my publish pages, and no textile default text formatting option.

Part of my difficulty in debugging is not knowing what to expect. Should I be seeing text editor buttons on all text areas (I see none)? Or should I be seeing text editor buttons only on certain fields? I can’t see how I would mark those fields as such if so.

Troubleshooting - here’s what I’ve tried so far:

TEH path: tried both “http://myhost/themes/third_party/teh” and “themes/third_party/teh”

I can reach http://myhost/themes/third_party/teh from my browser.

Help URL: I assume this doesn’t really matter. I left it as the default and I tried just “http://myhost”

I read something about JQuery for JPanel needs to be enabled, but that seems to be an EE1 mod. EE2 JQuery module is installed.

I also read something about the Editor buttons only appearing on fields that are marked as textile formatting. This option does not appear in the list, not even if I click “edit list” on the custom field page. Is there a textile field type or format that I’m supposed to install as well?

Fritz

imagehat
# 1
Developer
imagehat

Hi Fritzinger,

TEH doesn’t include the Textile plugin - you’ll need to download and install that separately first. http://devot-ee.com/add-ons/textile/

The toolbar only shows up for fields that have been set to use Textile formatting. So after installing the Textile plugin when setting up your custom field you’ll need to click “Edit List” and set Textile to “Yes” so it shows up in formatting options along with “Auto Br”, “None”, and “XHTML”.

After that the expected behavior is that if the default formatting for your field is set to Textile then the toolbar will load when the Edit entry page loads. If Textile is an available format, and you’d set “Allow override on publish page?” to yes so you can change the formatting in the edit screen, then the toolbar will toggle on and off as you change the format selection in the edit screen.

Hope that makes sense…

Fritzinger
# 2
Fritzinger

Fantastic, that works. Knew I was missing something obvious.

Nine Four Ltd.
# 3
Nine Four Ltd.

Everythings setup and on my server - the TEH extention is enabled, but when I go to field formatting textile doesnt appear on the list.

Any ideas?

Moonbeetle
# 4
Moonbeetle

I had a similar problem on an EE 2.2.1 clean install but found a way to fix it.

Channel preferences > Publishing page customization > Display Rich Formatting Buttons : YES
Custom field > Field options >
- Default Text Formatting for This Field: Textile (disabled all other types)
- Allow override on publish page? NO
- Show Formatting Buttons? YES

Still the TEH toolbar didn’t show. Then I just disabled and re-enabled the TEH extension et voilĂ ...fixed!

Nine Four Ltd.
# 5
Nine Four Ltd.

Hi Moonbeetle,

Thank for the response…. I’ve tried what ou said and it still doesnt show.

The problem I have is:

- Default Text Formatting for This Field: Textile isnt listed.

I’ve dis-ables the extension, and removed and re-uploaded it.

I also dis-abled all extensions and it still doesnt appear in the list.

:(

Moonbeetle
# 6
Moonbeetle

Do you have Textile installed? You need both. Textile and TEH. You can get Textile for EE here: http://devot-ee.com/add-ons/textile

In case you hadn’t installed Textile, after installation, go back to all your custom fields where you want to use Textile and make sure to enable and select Textile as the format type for those custom fields. This is a two step process. First you need to edit the list of types and enable Textile (optionally disable other types), then you need to set the type dropdown to Textile. I know there was a way to have Textile enabled straight away but I forgot.

Nine Four Ltd.
# 7
Nine Four Ltd.

BANG ITS WORKING!!

Didnt realise the plugin was required (slaps forehead).

Thanks for the help everyonee :)