Plugin

Developer
Supported

Switchee

ExpressionEngine 1.x, ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4

Back to this add-on's main page
View Other Add-ons From Mark Croxton

     

You must be logged in to post.

Switchee for EE5?

Support Request

seeingis
seeingis

Does the current version of Switchee work for ExpressionEngine 5?

Please advise.

Mark Croxton
# 1
Developer
Mark Croxton

Yes it does.

jcd
# 2
jcd

I’m getting errors regarding deprecated functions. Will this be addressed in future release?

Deprecated function assign_variables() called in /home/****/public_html/system/user/addons/switchee/pi.switchee.php on line 123.

From template tag exp:switchee:__construct in

Deprecated since 4.0. Use ee(‘Variables/Parser’)->extractVariables() instead.

 

Mark Croxton
# 3
Developer
Mark Croxton

Make sure you’re using 3.0.1.

https://github.com/croxton/Switchee

msunickb
# 4
msunickb

Will there be an update for EE6?