Extension, Module

Developer
Supported

Super Restricted Entries

ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From Amici Infotech

     

You must be logged in to post.

Super Restricted Entries conflicts with Publisher

Bug Report

pixi
pixi

Hi,

Since installing Super Restricted Entries the Publisher add-on (used to translate website contents) doesn’t work properly.

When I uninstall Super Restricted Entries it works normally.
I contacted the support of Publisher and they tell me that the hook you use for Super Restricted Entries is not correctly used and told me to ask you to check the last_call property, e.g.

public function channel_entries_query_result($channel, $results)
  {
      if (ee()->extensions->last_call !== false) {
        $results = ee()->extensions->last_call;
      }

The issue comes probably from there.

Can you give me a fix on this issue please?

Thanks in advance.

Amici Infotech
# 1
Developer
Amici Infotech

Hi,

I would love to fix it if it is on our end. Can you please tell me what exactly doesn’t work properly for you? any examples or links that helps me to identify issue?

Thanks,
Mufi
[Amici Infotech Support]

pixi
# 2
pixi

That is quite fast response!

I can give you the URL of the ticket support I opened on Publisher support forum, there it is : https://boldminded.com/support/ticket/2014

It is enough for you?

Thanks

Amici Infotech
# 3
Developer
Amici Infotech

Okay I guess I figure out the issue. I will update you asap. I am really sorry for the trouble your are facing for this.

Thanks,
Mufi
[Amici Infotech Support]

Amici Infotech
# 4
Developer
Amici Infotech

Hi,

I guess issue is now resolved. Can you please download and install v1.0.1 from here? https://devot-ee.com/add-ons/super-restricted-entries

Let me know the output you get this time.

Thanks,
Mufi
[Amici Infotech Support]

pixi
# 5
pixi

Yes! Publisher works absolutely perfectly now! thanks.

But now I have another issue that didn’t occur before the change.

I output the entries that the logged in user can access in a menu (with apply_super_restricted_entries=“yes”) and it outputs an entry link that it shouldn’t. When I click on the link (with url_title_path) and go to the entry’s page where there is {if super_restricted_entries:granted} tag it resticts the acces correctly.

Amici Infotech
# 6
Developer
Amici Infotech

Can you please share the code with me?

Thanks,
Mufi
[Amici Infotech Support]

pixi
# 7
pixi
<nav>
<
ul>
{exp:channel:entries channel="committee" dynamic="no" disable="categories|category_fields|member_data|pagination" sort="asc" apply_super_restricted_entries="yes"}
<li><a href="{url_title_path='intranet/committee'}">{title}</a></li>
{/exp:channel:entries}
</ul>
</
nav

and in the entry template :

{if super_restricted_entries:granted}
{title}
<div id="page_content">{page_content}</div>
{if:else}
<p>{phrase:intranet__p__if_member_group_restricted_entry}</p>
{/if} 

If I change the group member of the member I always see an entry that the member shouldn’t have access to in the menu.

pixi
# 8
pixi

I cheked the DB and the group access id’s listed in front of every entries id seems correct.

Amici Infotech
# 9
Developer
Amici Infotech

That’s strange. Everything is working good on my end. As far I understand the issue is, In navigation restricted links are showing somehow that links should be hidden for given member. When you click on link and go to detail page, entry restriction works good. Right?


- Can you make sure you are not logged in with super admin when all those links are visible in menu?
- Make sure you are not using ce:cache plugin and if you are, you have marked those code under ce_cache:escape.

If not the case, Can you please upload site to some staging server and email me link, admin url and password with FTP to .(JavaScript must be enabled to view this email address) so I can debug the issue?

Thanks,
Mufi
[Amici Infotech Support]

pixi
# 10
pixi

I was creating you a member account from my home PC and there everything works as expected…

Let me see tomorrow from my office PC and let you know but it is very weird (does browser cache play’s in this ??, definitely weird).

Amici Infotech
# 11
Developer
Amici Infotech

I dont suspect browser cache but I have to check/debug your templates. Let me know what you find out in your office PC. If issue exists there, try the same thing in incognito browser.

pixi
# 12
pixi

Hi Mufi,

I checked from my office PC (on 2 different browser as always) and everything is just fine now. Actually I don’t know what caused the issue yesterday (and yet it’s not for lack of having tested long before alerting you).

I am sorry I bothered you with this second problem that isn’t one actually!

Thanks for the very fast support and for your very useful add-on that comes at a perfect time in my project!

Amici Infotech
# 13
Developer
Amici Infotech

Good to know everything is just fine now. I am closing this ticket.

Thanks,
Mufi
[Amici Infotech Support]