Fieldtype, Module

Developer
Supported

SoundClouded

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Derek Hogue

     

You must be logged in to post.

PHP error in mod.soundclouded.php - EE_Pagination::create()

General (Resolved)

jadamfox
jadamfox

Just purchased a SoundClouded license and get PHP errors on first attempt of using:

Message: Missing argument 1 for EE_Pagination::create(), called in /var/www/html/dev.outsidegulfstream.com/system/expressionengine/third_party/soundclouded/mod.soundclouded.php on line 252 and defined

Filename: libraries/EE_Pagination.php

Line Number: 35

And

Message: Undefined variable: classname

Filename: libraries/EE_Pagination.php

Line Number: 37

And

Fatal error: Call to undefined method Pagination_object::prepare() in /var/www/html/dev.outsidegulfstream.com/system/expressionengine/third_party/soundclouded/mod.soundclouded.php on line 253


Running EE2 v2.7.3
I have already searched online and checked for the ee()->load->libary misspelling. I couldn’t find that issue. I don’t think my EE has that issue.

Derek Hogue
# 1
Developer
Derek Hogue

Ah - SoundClouded requires EE 2.8 or later, hence the issue. (The new pagination library was added in 2.8.)

jadamfox
# 2
jadamfox
Derek Hogue - 13 November 2017 01:12 PM

Ah - SoundClouded requires EE 2.8 or later, hence the issue. (The new pagination library was added in 2.8.)

Thank you. Bad on me for not digging in and catching that on the amphibian.info page. I purchased from Devot-ee and it only states “EE2” without a version number. A little misleading for those lazy, like myself, that miss the version requirement.

I’ll hang onto the license on the chance that we upgrade.

Derek Hogue
# 3
Developer
Derek Hogue

No worries. Just FYI, the devot:ee page does list EE 2.8 as the minimum version in the sidebar, near the purchase link. Easy to miss though.