Extension

Developer
Supported

Snaptcha

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5, ExpressionEngine 6

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Snaptcha & USER Mod Reg Form

Support (Resolved)

EverCherStudios
EverCherStudios

Good morning! I’m trying to implement Snaptcha on a registration form, which I’m generating using the “User” add-on. (User version 5.4.0, Snaptcha version 3.0.0).

I’ve read through the documentation for Snaptcha and have tried several ways to get it to work, but regardless of settings changes in the mod, I’m met with the following error:

“The form you submitted contained the following errors:

You must submit the word that appears in the image”

(NOTE: I do NOT have any native Captcha tags set within this form.)

I’ve tried the following ways:

Member Registration Validation” 
- ENABLED with template tag added to form
- DISABLED with template tag added to form
- ENABLED with NO tag
- DISABLED with NO tag

Nothing remedies this error, so I’m at your mercy. Your guidance is appreciated!

FYI: I am using ExpressionEngine v. 6.0.3.

Thanks!

PutYourLightsOn
# 1
Developer
PutYourLightsOn

The error “You must submit the word that appears in the image” has nothing to do with Snaptcha. It sounds like Captcha is still enabled somewhere, can you please double check?

EverCherStudios
# 2
EverCherStudios

Good morning! Thanks for getting back to me.

Something that wasn’t mentioned in your documentation is to disable the CAPTCHA setting in EE. My presumption was that regardless of that being enabled, if I didn’t add the CAPTCHA code to the form, it wouldn’t be an issue when using an outside plugin. Perhaps that was my fault. In any case, I disabled the Require Captcha setting in the native EE settings. When clearing all my cookies and re-adding the SNAPTCHA field to my User Reg form, filling it out, and submitting, I’m then met with this error:

A Database Error Occurred
You must use the “set” method to update an entry.

File location: /home/foo/bar/ee/ExpressionEngine/Service/Model/Query/Insert.php
Line number: 70

I opened up that file and here is the section for that error, with Line 70 in bold text:

$query = $this->store
        ->rawQuery()
        ->set($values)
        ->insert($gateway->getTableName());

I don’t work with PHP; therefore, that makes no sense to me. How do I go about just getting it to WORK?

Thanks!

EverCherStudios
# 3
EverCherStudios

UPDATE: Removed the template tag for SNAPTCHA from the form. When inspecting the page, there is no rendering of SNAPTCHA anywhere in the code, but when I fill out the registration form & submit it, I’m now met with the error message of “You failed the security test….”. I personally have javascript enabled in my browser, and I’m clearly not a bot. LOL

Yes, I have the registration form validation enabled, because of course, I want it to be protected. I know in your screenshot, you show that disabled, but what, then, is the point of using it? Thanks so much for any clarification you can provide! :)

PutYourLightsOn
# 4
Developer
PutYourLightsOn

You need to add the `{exp:snaptcha:field}` tag to your form for validation to pass. If that is throwing an error then can you please paste the full stack trace here?