Extension

Developer
Supported

Snaptcha

ExpressionEngine 2, ExpressionEngine 3

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Snaptcha rejecting all submissions from member registration form

Support (Resolved)

Dipsacus
Dipsacus

I have pasted the given code into my member/registration form and tried submitting at all three security levels, but it rejects them all.
Using EE3.3.1 Zurb Foundation 6 with modernizr

This is the code I pasted in from Snaptcha settings:
<div class=“snap” style=“position: absolute !important; height: 0 !important;  overflow: hidden !important;”><input type=“text” id=“snap_qThxalWJj” name=“snap_qThxalWJj” value=”” /></div>

PutYourLightsOn
# 1
Developer
PutYourLightsOn

Are you running the latest version 2.0.2 of Snaptcha? There should be some javascript code to go along with the html code provided, have you pasted that into the form as well? Can you send us a link to the form?

linglau
# 2
linglau

Hi,

I am getting the same. It’s coming up with the error message when I try and complete a registration.

I’ve pasted in the following inside the form:

<div class="snap" style="position: absolute !important; height: 0 !important;  overflow: hidden !important;"><input type="text" id="snap_bYCWccSVT" name="snap_bYCWccSVT" value="wVUIdVWtyEkIv" /></div>
[removed]document.getElementById("snap_bYCWccSVT").value "gaxRssgstXdee";[removed] 

and I’ve also put the snaptcha tag in (not sure if I have to) as so:

{exp:snaptcha:field} 

The form always fails and it does not tell me why or what to fix or if i’m filling in the form incorrectly.

If you could help that would be really appreciated!

 

PutYourLightsOn
# 3
Developer
PutYourLightsOn

What version of Snaptcha are you using and what security level is it set to? Also are you using EE’s native Member Profile Templates for the registration form? If so then there are specific instructions for setting it up in this section of the docs.

linglau
# 4
linglau

I’m using Snaptcha 2.0.2 and it’s set to Highest Security Level. I am using Native Member Profile template. I’ve followed the instructions on that page as I’ve detailed above.

I ended up putting it on Medium Setting (where more than one try is allowed) and that works. I think that was what the problem was. I followed your testing method when it was set to the highest level (where you delete input and submit) and because I already submitted once, it was just not letting me actually register after that. At least, I believe that this is what was causing the issue. What’s the time limit for an IP to make another try when it’s set to the highest level?

PutYourLightsOn
# 5
Developer
PutYourLightsOn

Yes, you’ll want to use the medium security level for native member profile templates. If that now works then you’re all set!!

There is no time limit per IP address.

linglau
# 6
linglau

So just to be absolutely sure, the Highest Security level does not work for EE native member profile templates?

PutYourLightsOn
# 7
Developer
PutYourLightsOn

Correct.