Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

child categories

Support (Resolved)

PP
PP

Hi,

I just set up sitemap for a website where entries of one channel are located at domain.com/cat_url/url_title
Some of the entries have a child category and I am always using the child category in segement_1 never the parent.

So I set up this channel to domain.com/{cat_url_title}/{url_title} in the Sitemap settings. It’s working great and the urls are using the child categries if it has parent. But some how for one categegory it’s using the parent category. Other categrories with the same parent are working fine.

What can I be doing wrong?

Thanks,
Philip

PutYourLightsOn
# 1
Developer
PutYourLightsOn

in the case of the entry that is getting the parent category, are both the child and parent categories selected as the categories of the entry? and if so then would you be able to deselect the parent category?

PP
# 2
PP

Both categories are selected. And they need be selected. All All other entries with a parent have also both selected, and they are working fine. Even the one with the same parent.

PutYourLightsOn
# 3
Developer
PutYourLightsOn

for the one stubborn entry, please try deselecting the parent category, updating the entry, and then go back in and reselect it and update. it might work, if not then try doing the same but with deselecting the child category first.