Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

I’m only getting the homepage in the sitemap

Support (Resolved)

adlitinc
adlitinc

The sitemap shows the homepage but nothing else:

http://dev.mywebsite.com/site/sitemap

<?xml version=“1.0” encoding=“UTF-8”?>
<urlset xmlns=“http://www.sitemaps.org/schemas/sitemap/0.9”>
 
<url>
<loc>http://dev.mywebsite.com/</loc>
<lastmod>2013-01-03T13:05:57-05:00</lastmod>
<changefreq>daily</changefreq>
0.5</priority>
</url> 
   
</urlset>

<!—Generated by the EE Sitemap Module v2.6—>

I do have a number of channels included and a couple excluded.

What did I miss?

PutYourLightsOn
# 1
Developer
PutYourLightsOn

do you have open entries in the channels that are included?

adlitinc
# 2
adlitinc

yes I do have over 200 of open entries in several channels.

Let me know what else I can try

PutYourLightsOn
# 3
Developer
PutYourLightsOn

can you please attach a screenshot of your Sitemap module settings page

adlitinc
# 4
adlitinc

I’ve just emailed the screenshots

adlitinc
# 5
adlitinc

I’ve just emailed the screenshots

PutYourLightsOn
# 6
Developer
PutYourLightsOn

thanks, i received it but i don’t see any statuses in the status column. don’t you have any status groups assigned for those channels? the Sitemap module looks for “open” entries by default and since you don’t have any the sitemap is coming up empty.

adlitinc
# 7
adlitinc

That was it! Thanks

PutYourLightsOn
# 8
Developer
PutYourLightsOn

glad to hear that worked