Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Some problems/questions with sitemap module

General

northk
northk

Greetings,

I’ve installed and enabled the sitemap module but I have some questions:

1 - when I click on View Rendered Sitemap, the URL is generated incorrectly (with an extra slash) as http://www.highintegritydesign.com//sitemap.php. However the page still loads, with or without the extra slash. Is this a problem?

The sitemap template is placed into the “quality-web-design” template group, so I modified sitemap.php to say $template = ‘quality-web-design/sitemap’;

2. I have additional items I need to include in the sitemap, outside of EE. I have a tinter-shader tool for designers that I want to include. Is there a way to do this?

3. In Google Webmaster Tools, I had it configured it to use a static sitemap ‘/sitemap.xml’ before purchasing the sitemap module. So I deleted the static sitemap from webmaster tools (and from my site), and then I re-submitted a new sitemap to Webmaster tools as ‘/sitemap.php’. Webmaster Tools seemed to like that OK. But was this the correct thing to do, or should I delete that sitemap from Webmaster Tools and use the “Submit Sitemap to Google Manually” button instead?

Thanks,
-NorthK

northk
# 1
northk

Ahh, I see how to add additional link locations now. Got that under control, but still need help with the other two questions.
Thanks,
-NorthK

PutYourLightsOn
# 2
Developer
PutYourLightsOn

hi northk,

1. not a problem but i will fix in next release

3. yes, you did it correctly.

ben