Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

XML Parsing Error: XML or text declaration not at start of entity

Support (Resolved)

Goodmixer
Goodmixer

Sitemap Module had been working on this EE build

but now getting error

XML Parsing Error: XML or text declaration not at start of entity in Firefox

or

This page contains the following errors:

error on line 7 at column 6: XML declaration allowed only at the start of the document
Below is a rendering of the page up to the first error.

in safari when I try to view the sitemap in the browser

Was running Sitemap 2.6.3 and EE 2.7.2

Upgraded to Sitemap 2.6.4 which made no difference.

Template in default site/sitemap and as xml type

Have you come across this one before?

Any assistance much appreciated.

PutYourLightsOn
# 1
Developer
PutYourLightsOn

can you post a link to the sitemap?

Goodmixer
# 2
Goodmixer

Sure Ben. Pls find below

http://quickstep.ie/site/sitemap

PutYourLightsOn
# 3
Developer
PutYourLightsOn

do you have any blank at the top of your sitemap template? that seems to be the issue.

Goodmixer
# 4
Goodmixer

No there’s no spaces just

{exp:sitemap:get} 

And template is xml type.

Goodmixer
# 5
Goodmixer

Ben,

Viewing the source of the sitemap shows 6 blank lines at the beginning of the xml file. I can’t determine what is causing this as there is no blank space in the template. I thought that perhaps there was a location that wasn’t being processed correctly in the file but they all seem to be there.

Is there any further light you could shine on this one? Silly season is approaching fast and would like to get this figured out.

PutYourLightsOn
# 6
Developer
PutYourLightsOn

it looks good to me. can you toggle the editor on to check that it really is the only line in there? and maybe then resave the template to double check? if that doesn’t help then you can email access details and i’l try to troubleshoot this for you.

Goodmixer
# 7
Goodmixer

Ben,

Thanks for getting back to me. Template looked fine. Deleted it and created new one. Same thing. Hardcoded the sitemap into template (less 6 blank lines). Template rendered with 6 blank lines again. Checked other templates. All seem to have same issue. Stumped….. but issue has nothing to do with your plugin. Thanks for offer but I’ll have to figure this one out myself.

PutYourLightsOn
# 8
Developer
PutYourLightsOn

ah ok, well good luck figuring out the spacing issue then!!