Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Unpopulated sitemap

Support (Resolved)

leenoble
leenoble

I’ve read through similar threads and not found a solution to this.

I confess to not being that proficient with EE, and I didn’t build this website.

The sitemap file is here http://webbplumbing.com.au/site/sitemap

but there’s nothing in it. I’ve set several of the channels to “Include” and the channels have entries with “Open” statuses.

ee version 2.5.5, latest version of sitemap module just installed. It also uses the structure plugin but I’m assuming those issues have now been resolved in the latest download.

I’ve left all the urls in the module configuration at their default. I’m not clear exactly what’s supposed to go in there if that’s wrong. I tried changing one of them, the one for “in the pipeline blog posts”, to http://webbplumbing.com.au/about/in-the-pipeline/{url_title} as that appears to match the page urls when navigating the front end of the site. Still nothing in the sitemap though.

I’m away for a couple of days so may not be able to respond until Monday. Cheers.
Lee

PutYourLightsOn
# 1
Developer
PutYourLightsOn

all sounds like it is properly set up. if you send me access details to the CP then i can look into it further.

PutYourLightsOn
# 2
Developer
PutYourLightsOn

after looking into it it seems that your channels do not have any status assigned to them. select “Statuses” in the Status Group dropdown and that should fix it.

leenoble
# 3
leenoble

Ah, ok. That seems to have done something. I’ve no idea how you’re supposed to know what that drop down does, it seems totally abstract, like far too many things in EE in my opinion. I’m used to coding with PHP not cryptic drop down menus ;)

Cheers
Lee

PutYourLightsOn
# 4
Developer
PutYourLightsOn

that’s EE for you