Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Sitemap not rendering - jumps to homepage

Support (Resolved)

Allan W.
Allan W.

Greetings. I’m bolting Sitemap Module on to another developers’ site, which is using the Taxonomy module for page organization. I’ve gone through the setup, and installed the template correctly.

http://dev.kaufmanmusiccenter.org/

When I try to view the sitemap, it just jumps to the home page, like there’s no template there. I wonder if it’s the .htaccess file, which is attached below.

It’s also using Taxonomy, which I’m not familiar with, but I think SiteMap supports. Do I have to ‘tell’ taxonomy about it, I wonder?

If you have any suggestions on what I can look at, or solutions, I would most appreciate it! Thank you.

- Allan White

AddHandler x-mapp-php5 .php
#php_flag display_errors off

#ErrorDocument 403 /kc/error-403
#AcceptPathInfo on

<IfModule mod_rewrite.c>
 
RewriteEngine on

# REMOVE UNSUPPORTED SUB-DOMAINS
 
RewriteCond %{HTTP_HOST} !^m2\.kaufmanmusiccenter\.org [NC]
 RewriteCond 
%{HTTP_HOST} !^m1\.kaufmanmusiccenter\.org [NC]
 RewriteCond 
%{HTTP_HOST} !^admin\.kaufmanmusiccenter\.org [NC]
 
# was used when redirect to domain w/o 'www.':
 #RewriteCond %{HTTP_HOST} ^([^.]+)\.(kaufmanmusiccenter\.[^/:]+) [NC]
 
RewriteCond %{HTTP_HOST} !^dev\.(kaufmanmusiccenter\.[^/:]+) [NC]
 RewriteRule 
^(.*)$ http://dev.kaufmanmusiccenter.org/$1 [R=301,L]

# REMOVE INDEX.PHP
 
RewriteCond $!\.(gif|jpe?g|png|pdf)$ [NC]
 RewriteCond 
%{REQUEST_FILENAME} !-f
 RewriteCond 
%{REQUEST_FILENAME} !-d
 RewriteRule 
^(.*)$ /index.php/$1 [L]
 
# If 404s, "No Input File" or every URL returns the same thing
 # make it /index.php?/$1 above (add the question mark) 
PutYourLightsOn
# 1
Developer
PutYourLightsOn

what is the name of the sitemap template you created and the name of the template group that the sitemap template is in?

Allan W.
# 2
Allan W.

Hi Ben, thanks for jumping in. The template is in a folder group called /kc (which holds the homepage) and is titled, “sitemap” (no extension). It’s type is set to XML, no caching, PHP off, parsing: output stage.

Appreciate your time!

PutYourLightsOn
# 3
Developer
PutYourLightsOn

hmm either your .htaccess file (which looks fine) or Taxonomy must be rerouting the request to the template. if you create a template called “test” in the same group with some dummy text then does it render? if not then that’s where you have to start debugging.

Allan W.
# 4
Allan W.

Will try that Ben, great suggestion.