Module

Developer
Supported

Sitemap Module

ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Google: Webmaster Tool shows error…

Support (Resolved)

belarga
belarga

Before submitting the sitemap on Webmaster’ tool. I ran a check and: “General HTTP error: 404 not found
HTTP Error: 404” If I go to the URL I get to see the sitemap.xml BTW, I only see the home and not any other of the links…

Any ideas?

PutYourLightsOn
# 1
Developer
PutYourLightsOn

try navigating to the template you set up. most likely just “sitemap” without the “.xml”.

belarga
# 2
belarga

I did that, several times. http://www.cajaderespuestas.com/site/sitemap I can see it and everything seems right but once I try to submit the same URL with or without .xml and in several other combinations, Google answers:

“We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.” Followed by a “General HTTP error: 404 not found. HTTP Error: 404”

So I’m guessing it has to do with 404 in EE? Is it not rendering the page?

PutYourLightsOn
# 3
Developer
PutYourLightsOn

your site/sitemap template is returning the template with a 404 status code. the following url does as well, which indicates an issue with your site and resolving this should resolve the sitemap issue with google.
http://www.cajaderespuestas.com/publicaciones/articulo/aprender-en-vacaciones

belarga
# 4
belarga

Yes, that’s exactly the issue but why can I see it? (attached file) and If there’s a 404 problem, how can I solve it? this site/sitemap is the only one presenting that problem. Your extension is not showing the page but still I can browse it. Any ideas? Do you think it has to do with a .htaccess issue as post it on: http://stackoverflow.com/questions/6542887/using-get-query-strings-with-expressionengine-and-structure or maybe a case similar to http://devot-ee.com/add-ons/support/sitemap-module/viewthread/8935 and have on mind that I’m on EE 2.6.1 and if it also helps I have installed NSM .htaccess Generator 1.1.5

PutYourLightsOn
# 5
Developer
PutYourLightsOn

the page you are seeing in the screenshot attached is correct. only the http status code is set to 404. it is not only happening on the sitemap template though, see the link and screenshot i posted above. it’s probably a .htaccess issue but is not related to the sitemap module so i can’t really help you with it.

belarga
# 6
belarga

Can you help me with your refund process?

PutYourLightsOn
# 7
Developer
PutYourLightsOn

sure, all refunds go through devot-ee so you can request one through your account here http://devot-ee.com/returns