Plugin

Archived
Forum
(read-only)

Jeremy Worboys does not actively monitor this forum
(but you can still get help from other EE users).

Simple MailChimp

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Jeremy Worboys

     

You must be logged in to post.

Submit button redirect to the home page

Support (Resolved)

lambdaka
lambdaka

Hi, I installed your add-ons and was able to create a form..but when I hit submit button, it’s redirected to the homepage of the website.
Errors or not, nothing else happens than a redirection to the homepage..

Did I miss something..?
here is the test I made:

{exp:simple_mailchimp
api_key
="*************57546cd-us5"
list_id="3c*********"
error_delimeters="<p class='error'>|</p>"}
    {if success}
        
<class="success">SuccessCheck your email to activate your subscription.</p>
    
{if:else}
        
<p>
            
{label:FNAME}
            {merge
:FNAME}
            {error
:FNAME}
        
</p>
        <
p>
            
{label:LNAME}
            {merge
:LNAME}
            {error
:LNAME}
        
</p>
        <
p>
            
{label:CITY}
            {merge
:CITY}
            {error
:CITY}
        
</p>
        <
p>
            
{label:EMAIL}
            {merge
:EMAIL}
            {error
:EMAIL}
        
</p>
        
{submit}
    {
/if}
{
/exp:simple_mailchimp} 

Thanks a lot for your work.

S.

Jeremy Worboys
# 1
Developer
Jeremy Worboys

Hey, your example all looks correct. This issue was resolved in version 1.1.0, can you check which version you have installed?

lambdaka
# 2
lambdaka

Hi, I’m using the 1.1.1,
I tried to add the attr:type=“text”, but nothing new..

Do you have an idea..?

lambdaka
# 3
lambdaka

hi again,
when I llok at the source code of my page here is what I found:


<form name=“simple_mailchimp” method=“post” action=”/index.php”  >

maybe it helps..
thanks

Jeremy Worboys
# 4
Developer
Jeremy Worboys

Hey, good catch with the form action, probably wouldn’t have seen the issue so quickly otherwise.

I have just uploaded version 1.1.2 which should resolve this issue. Can you test it out and confirm.

lambdaka
# 5
lambdaka

hehe, cool if my catch helped you..

thanks for the quick move..
if there is an error it’s ok, I got the message..
But if all the field are validate nothing seems to happen and I don’t get the succes message neither email to confirm
check it here

http://tinyurl.com/cso9zcs

thks

lambdaka
# 6
lambdaka

Maybe something with my parameters in Mailchimp, I put an url to redirect when the form is succesfully recorded..
..?

Jeremy Worboys
# 7
Developer
Jeremy Worboys

I have taken a look at the link you provided and I can confirm there is an issue. I am unable to reproduce this on my local machine.

If possible I would like to get access to the server that you are having these issues on. I will be sending you an email to continue with this.

Jeremy Worboys
# 8
Developer
Jeremy Worboys

For others that have a similar issue. We found the problem in this case to be that there were fields marked as required in MailChimp, that were not being used in the form.

Solutions to this are to: add them to the form (they’re probably required for a reason) or to change them in MailChimp to not be required.