Extension

Developer
Supported

reCAPTCHA v2

ExpressionEngine 1.x, ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From Denik

     

You must be logged in to post.

EE v2.3.1 with FreeForm 3.1.0 always return an error

Bug Report

lwtconnect
lwtconnect

I added reCAPTCHA to the Freeform. It always return an error without any error message
The form you submitted contained the following errors
Return to Previous Page

Denik
# 1
Developer
Denik

Hello,

Please check follow:
1. Disable any other captcha extensions.
2. Are JS-part work? Check your JavaScript code on conflicts with reCaptcha scripts.
3. Try to disable captcha verification in forms - error is gone?

If this does not help, then I’ll need to take a look myself. Please send SuperAdmin and FTP login credentials to hi at eecoding dot com if you can.

lwtconnect
# 2
lwtconnect

I don’t think I have other captcha extensions. I use the EE captcha. Should I turn this off?
I have some issues to add the js automatically. I included the js manually. I read in other post that I should use {freeform:captcha} instead {captcha}. I tried both. Only {captcha} added tag.
If I disabled the extension and removed the captcha, the form works fine.

Denik
# 3
Developer
Denik

Can you provide your form type settings (screenshot) and template markup under which recaptcha v2 not working ?

Also maybe you have error messages in logs (apache error_log) ?
And try to enable “Show response code on validation failure (debug)” in recaptcha v2 settings and “Display Template Debugging” in EE Output and Debugging settings.