Extension

Developer
Supported

reCAPTCHA v2

ExpressionEngine 1.x, ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4

Back to this add-on's main page
View Other Add-ons From Denik

     

You must be logged in to post.

reCaptcha not appearing (using Freeform)

Bug Report

jtrascap
jtrascap

Using EE 3.5.14, and Freeform Pro Classic v5.2.0

I’ve installed the plugin and created the accompanying reCaptcha keys, and added them to the template. The form page is non-dynamic (dynamic=“no”).

I’ve then added the simple if_captcha pair to the page, as per the docs:

{if captcha}
    {captcha}
{
/if} 

Seeing nothing, I’ve added the code below, even though it’s not a dynamic page: 

$("#my_form_name").load('/the_form_page', function(){
    document
.reCAPTCHAv2(
        $(
this).find('.g-recaptcha')
    );
}); 

Still no reCaptcha on the page. That last half (load(’/the_form_page’) wants to load the page again in the footer, so clearly I’m doing something wrong. I’d appreciate any help.

Denik
# 1
Developer
Denik

Hello,
Are there any errors in the console log of your browser?

jtrascap
# 2
jtrascap

I’m seeing nothing - nothing in the load or once sent. The plugin doesn’t seem to be initialised.

Denik
# 3
Developer
Denik

Hello,
Please, try to new version 1.0.2.

pbrienesse
# 4
pbrienesse

With Freeform you must use

{if freeform:captcha}
  {freeform
:captcha} 
{
/if} 

instead of

{captcha} 
DSI
# 5
DSI

THANK YOU!

Finally - A simple answer to a simple question!! The ‘documentation’ for this plugin leaves much to be desired:

WRONG INSTRUCTIONS:

“Installation for ExpressionEngine v2.x
Upload the recaptchav2 folder to system/expressionengine/third_party
Enable and configure the extension via Add-Ons > Extensions
Remove the hard-coded CAPTCHA input field from your member registration template (../themes/profile_themes/[theme_name]/registration_form.html) and any comment submission form templates so that the CAPTCHA’s conditional block looks like:

{if captcha}
  {captcha}
{/if}”

RIGHT INSTRUCTIONS:

Installation for ExpressionEngine v2.x
Upload the recaptchav2 folder to system/expressionengine/third_party
Enable and configure the extension via Add-Ons > Extensions
Remove the hard-coded CAPTCHA input field from your member registration template (../themes/profile_themes/[theme_name]/registration_form.html) and any comment submission form templates so that the CAPTCHA’s conditional block looks like:

{if freeform:captcha}
  {freeform:captcha}
{/if}

THANK YOU AGAIN!!!!