Extension

Developer
Supported

reCAPTCHA v2

ExpressionEngine 1.x, ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5, ExpressionEngine 6

Back to this add-on's main page
View Other Add-ons From Denik

     

You must be logged in to post.

Implemented plugin, still getting spam

Support Request

Dovla
Dovla

I’m using EE v2.11.3 and Freeform 4.2.5…I’ve implemented the plugin and everything seems to work. I can’t submit the form unless I solve the captcha and I’ve tried to send it with javascript disabled and it won’t submit either. But I’m still getting a lot of spam on a daily basis.

When I log in to manage the recaptcha and go to download analytics it’s always empty and I can’t get any stats. Is there a way to check that recaptcha is working correctly? Here’s the freeform code I’m using..I’ve removed some extra html

{exp:freeform:form
    form_id
="1"
    
require_captcha="yes"
    
require_ip="yes"
    
required="name|email|subject|user_message"
    
return="about-us/thanks"
    
inline_errors="yes"
    
secure_action="no"
    
secure_return="no"
}
<label for="name">{freeform:label:name}:</label>
    
{freeform:field:name attr:class="Form-input" attr:data-validation="required" attr:data-validation-error-msg="You did not enter a Name"}
<label for="from">{freeform:label:email}:</label>
    
{freeform:field:email attr:class="Form-input" attr:data-validation="email"}
<label for="subject">{freeform:label:subject}:</label>
    
{freeform:field:subject attr:class="Form-input" attr:data-validation="required" attr:data-validation-error-msg="You did not enter a Subject"}
<label for="user_message">{freeform:label:user_message}:</label>
    
{freeform:field:user_message attr:class="Form-textarea" attr:data-validation="required" attr:data-validation-error-msg="You did not enter a Message"}
    {if freeform
:error:user_message}
        
<span class="error">Please enter a message</span>
    
{/if}
    {if freeform
:captcha}{freeform:captcha}{/if}
    {freeform
:submit attr:class="Button"}
{
/exp:freeform:form} 
Denik
# 1
Developer
Denik

Hello,
Very similar to the situation when some template has form which the captcha is disabled (require_captcha = “no”).
You make sure to CAPTCHA is enabled for all your forms in all templates?

If in the above example captcha work properly, then I would look for the problem in other templates.

Dovla
# 2
Dovla

Every form on the page has require_captcha=“yes” just like in the example I posted above…I have also enabled captcha for logged in members in EE settings. The captcha displays fine on the contact page and everything works…but I am still getting spammed and when I log in to recaptcha there are no analytics to download…like it’s not working at all. I also turned on the debug option in the extension and nothing helps

Denik
# 3
Developer
Denik

I’ll need to take a look myself. Please send SuperAdmin and FTP login credentials to hi at eecoding dot com if you can.

Dovla
# 4
Dovla

email sent, thanks in advance

Denik
# 5
Developer
Denik

Hello,

After detailed study, was found form without captcha required (main/index).
I added freeform:captcha field in form, and now spam will be stopped (if you do not have more forms without captcha).

best regards

Dovla
# 6
Dovla

thank you so much! I can’t believe I forgot about the second form on the main page…spent so much time changing stuff that I forgot I had two forms on the site