Module

Developer
Supported

PDF Press

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5, ExpressionEngine 6

Back to this add-on's main page
View Other Add-ons From Doug Black, Jr.

     

You must be logged in to post.

PDF Press Error After Upgrading EE 2

Support Request

capstonedesign
capstonedesign

Hello. I am upgrading an EE2 installation and I am getting the following error using PDF Press version 4.0.3. Any ideas on what to do?


SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘shellydb.exp_pdf_press_options’ doesn’t exist:
SELECT * FROM (`exp_pdf_press_options`) WHERE `site_id` = 1
ee/legacy/database/drivers/mysqli/mysqli_connection.php:116

Stack Trace: Please include when reporting this error
#0 ee/legacy/database/drivers/mysqli/mysqli_driver.php(111): CI_DB_mysqli_connection->query(‘SELECT *\nFROM (...’)
#1 ee/legacy/database/DB_driver.php(269): CI_DB_mysqli_driver->_execute(‘SELECT *\nFROM (...’)
#2 ee/legacy/database/DB_driver.php(179): CI_DB_driver->simple_query(‘SELECT *\nFROM (...’)
#3 ee/legacy/database/DB_active_rec.php(1205): CI_DB_driver->query(‘SELECT *\nFROM (...’)
#4 user/addons/pdf_press/mcp.pdf_press.php(94): CI_DB_active_record->get_where(‘pdf_press_optio…’, Array)
#5 [internal function]: Pdf_press_mcp->index()
#6 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(1661): call_user_func_array(Array, Array)
#7 ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php(945): EllisLab\ExpressionEngine\Controller\Addons\Addons->getModuleSettings(‘pdf_press’, ‘index’, Array)
#8 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->settings(‘pdf_press’)
#9 ee/EllisLab/ExpressionEngine/Core/Core.php(240): call_user_func_array(Array, Array)
#10 ee/EllisLab/ExpressionEngine/Core/Core.php(109): EllisLab\ExpressionEngine\Core\Core->runController(Array)
#11 ee/EllisLab/ExpressionEngine/Boot/boot.php(146): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request))
#12 admin.php(147): require_once(’...’)
#12 admin.php(147): require_once(’...’)

capstonedesign
# 1
capstonedesign

I should mention I am in EE 4.3.8 in the upgrade process at this point.