Fieldtype

Developer
Supported

Nolan

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From iain

     

You must be logged in to post.

Php errors after upgrading 1.0.3.1 to 2.4.1

General

96black
96black

Hi Iain,
I’ve run into an issue while upgrading a clients site. Evidently the Nolan version installed was an older one (V1.0.3.1), and I upgraded it to V2.4.1 during a routine EE upgrade from EE V2.7.1 to 2.8.1.

FYI in the back end the Nolan fields render, but they’re all empty. On the front end is where these errors are being reported.

A PHP Error was encountered

Severity: Warning

Message: array_slice() expects parameter 1 to be array, null given

Filename: nolan/ft.nolan.php

Line Number: 331


Have you come across this before?

Thanks Iain.

iain
# 1
Developer
iain

Hey, did you read the important upgrade instructions highlighted in red on the documentation?

http://iain.co.nz/software/docs/nolan

96black
# 2
96black

No I hadn’t read the giant red box highlighted in the documentation (...sorry).

I made those tweaks and it all works perfectly now.

Thanks for the fast response Iain.

iain
# 3
Developer
iain

haha! All good :)