Extension, Plugin

Developer
Supported

Minimee

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From John D. Wells

     

You must be logged in to post.

[Resolved] Valid HTML 4 tag

Feature Request

Leon Dijk (GWcode)
Leon Dijk (GWcode)

Hi John,

This isn’t a big deal as it’s easy to change myself, but the following feature would be nice (so I wouldn’t have to hack the pi.minimee.php file every time there’s an update):

A setting where you can choose if the output of the stylesheet tag should be for HTML or XHTML.

I’m using a HTML 4 Strict doctype, which doesn’t validate because the stylesheet tag uses

/> 

at the end.

Thanks for the great add-on!

Leon

*reason for edit: my example code broke in the editor :) *

John D Wells
# 1
Developer
John D Wells

Hi Leon,

Thanks for bringing this up - I’d actually quietly wondered if anyone might want to control the outputted tags.  :)

I’m trying to determine the best way to handle this, and here’s my thought:

Take the first <link…> (or <script ...>) tag encountered, and use it as the template for final output.

This would have the added benefit of effectively making the media parameter obsolete.

I’ll add this to the next release.  So glad you’ve found Minimee useful - anything else, please let me know.

Cheers,
John

Leon Dijk (GWcode)
# 2
Leon Dijk (GWcode)

Hi John,

That makes perfect sense. It wouldn’t require a new settings option that way.

Thanks for the quick reply, minimee is now on my default list of add-ons :)
Love the {stylesheet} global introduced in 1.0.2!

Leon

John D Wells
# 3
Developer
John D Wells

Hi Leon,

I’ve attached what is effectively a patch that adds this “template” functionality.  The code is still marked as version 1.0.2, so whenever I do a proper update to 1.0.3 you’ll still be notified (if you use NSM Addon Updater of course).

Of course give a shout if anything goes awry.

Awesome that Minimee is in your default list of addons!  Music to my ears. :)

Cheers,
John

File Attachments
minimee-v1.0.2-r66.zip  (File Size: 23KB - Downloads: 171)
Leon Dijk (GWcode)
# 4
Leon Dijk (GWcode)

Looks like it’s working John, it didn’t break anything, works without the media parameter and validates as HTML 4 strict now.

Yes, I’m using NSM Addon Updater, looking forward to the next release. Great job and thanks again!

Leon