Fieldtype

Developer
Supported

Member List Custom Field

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Christopher Imrie

     

You must be logged in to post.

safecracker error

Support Request

imagineer
imagineer

Error message when using field:myfieldname in safecracker front end form

A PHP Error was encountered

Severity: Warning
Message: array_key_exists() [function.array-key-exists]: The first argument should be either a string or an integer
Filename: cki_mblist/ft.cki_mblist.php
Line Number: 54

imagineer
# 1
imagineer

CKI Memberlist v 1.31
EE 2.51

{field:myfieldname}

imagineer
# 2
imagineer

The drop down list appears correctly. So Im unsure as to why the error is displaying.

wsmith
# 3
wsmith

This is what is causing the error. It looks like it could easily be fixed:

Deprecated function EE_Fieldtype() called in system/expressionengine/third_party/cki_mblist/ft.cki_mblist.php on line 20.
From template tag exp:channel:form in xxx/yyy.
Deprecated since 2.6. Use EE_Fieldtype::__construct() instead.

wsmith
# 4
wsmith

If gzip output is set up you get this error when using this fieldtype:

This webpage is not available
The webpage at http://leveller.org/eetest/index.php/oms/crud might be temporarily down or it may have moved permanently to a new web address.
Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.