Plugin

Developer
Supported

Loop Plugin

ExpressionEngine 1.x, ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Plugin not working - EE v2.9.2

Support (Resolved)

EEuser001
EEuser001

Hi

I have correctly installed the Loop Plugin to system/expressionengine/third_party/for_loop, but I’m getting the error:

The following tag has a syntax error:

{exp:for_loop}

Please correct the syntax in your template

All I’m doing is trying out an example that is on the Plugin website.The version of ExpressionEngine I’m using is 2.9.2 and the Plugin version is 1.4.

I hope you can help me.

PutYourLightsOn
# 1
Developer
PutYourLightsOn

What exactly are you trying to do with your code? Can you paste your full code sample so we can see it?

EEuser001
# 2
EEuser001

All I’m currently doing is testing out the example within my template.

{exp:channel:entries category="{if segment_2 == 'shoots'}26{if:elseif segment_2 == 'hype'}2{if:else}{embed:category_id}{/if}" channel="news" status="open" orderby="date" limit="18" sort="desc" paginate="bottom"}
    {exp
:stats channel="news"}
        {exp
:for_loop start="0" end="33" increment="3"}  
             {index} 
        {
/exp:for_loop}
    {
/exp:stats}
{
/exp:channel:entries} 

Hope this helps.

 

PutYourLightsOn
# 3
Developer
PutYourLightsOn

Your syntax looks fine to me, have you tested it in a template on its own?

EEuser001
# 4
EEuser001

Yes I have, and still the same result.

PutYourLightsOn
# 5
Developer
PutYourLightsOn

Please double check that you have uploaded the add-on files to the correct location. Also please check that the Loop Plugin is listed on the plugins page in the control panel, as the error message indicates that the tag does not exist.