Fieldtype

Archived
Forum
(read-only)

Jeremy Worboys does not actively monitor this forum
(but you can still get help from other EE users).

JW Nivo

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Jeremy Worboys

     

You must be logged in to post.

Unable to load the requested class: file_field

General (Resolved)

oyvindokland
oyvindokland

Hi,
I am struggeling to get the plugin to work.
1. First I got the “Fatal error: Call to undefined function ee()”  when installing it.
2. So I downgraded to the 1.2.2 version as suggested here  (by the way I am running ee2.6.1) - and it installed fine.
3. Then when trying to reach the Publish page I get “Unable to load the requested class: file_field” - any ideas?

Thank you

- Oyvind

Jeremy Worboys
# 1
Developer
Jeremy Worboys

Hey Oyvind,

I’m not sure why version 1.3.1 wasn’t working for you if you are on EE 2.6.1.

Judging by the error I would say you need to have the native File Field module installed.

oyvindokland
# 2
oyvindokland

Hi again,
File_Field is already installed. I have tried to re-install both the system and the plugin, but still the same error.

Jeremy Worboys
# 3
Developer
Jeremy Worboys

Hmm… strange.

What version of PHP are you running? I will try to recreate your environment to see if I can reproduce. Is there anything our of the ordinary with your EE install?

jojoShay
# 4
jojoShay

I just purchased the add-on and I am getting the same error once I try to create a new entry in my channel.  I am using a really old version of EE… 2.1.3.  I tried installing the previous version of JW Nivo from another post, but I received the same error.  Is it compatible?

Joe

FYI:  *** I’m still using the safecracker add-on ***

Jeremy Worboys
# 5
Developer
Jeremy Worboys

Hey Joe,

This add-on was initially developed against EE 2.4 or 2.5 so it has never been tested with a version that old.

I no longer actively support versions of EE below 2.6, however if you still have a copy of the installation .zip for EE 2.1.x I can attempt to get it working for you. If you have this file, please send it to jw@jeremyworboys.com and I will take a look.

jojoShay
# 6
jojoShay

Jeremy,

Thanks for the quick response.  Well to make a long story (kinda) short, I’ve spend all day in the “cage” with EE.  Boy do I love what this product is capable of, but the evolution between versions is a digital nightmare.  The forum are a god send but left me just short of my goal.  After my posted question I tried your add-on with a clean install of EE and it worked flawlessly.  I then tried to upgrade my customer twice today from 2.1.3 to 2.8.0.

The first time was riddled with PHP errors from plugins that were out of date and could not be updated.  Reverted to my backup.  Researched and installed all the updates.  Upgraded again only to find more PHP errors.  Worked through most of them, but SafeCracker was really jacking me up.  Forums say just install v2.2.  Try finding that.  You have a better chance of wining the lotto.  Playa was acting up.  Direct SQL edit was the fix.  BLAH BLAH BLAH. and then the templates wouldn’t display past the home page.  BUMP THAT!!!  Reverted back to 2.1.3.

Basically I can’t use your add-on.  It’s the perfect solution otherwise.