Fieldtype

Developer
Supported

Issuu

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Milan Topalov

     

You must be logged in to post.

PHP Error with Issuu

Bug Report

seeingis
seeingis

Running version 0.5.4 of Issue
Expresion Engine: 2.6.1

Error

A PHP Error was encountered
Severity: Warning
Message: file_get_contents() [function.file-get-contents]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0
Filename: issuu/ft.issuu.php
Line Number: 414

A PHP Error was encountered
Severity: Warning
Message: file_get_contents(http://api.issuu.com/1_0?action=issuu.folders.list&apiKey;=&folderSortBy=name&format=json&pageSize=30&responseParams=folderId,name,description,items,created&resultOrder=asc&startIndex=0&signature=1e131d743f7065010f028c46646612b8) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found
Filename: issuu/ft.issuu.php
Line Number: 414

A PHP Error was encountered
Severity: Warning
Message: Cannot modify header information - headers already sent by (output started at /nfs/c08/h04/mnt/171999/domains/seeingis.net/html/symphony/codeigniter/system/core/Exceptions.php:170)
Filename: core/Common.php
Line Number: 408

Jean-Michel
# 1
Jean-Michel

Same issue here. Any workaround?

Milan Topalov
# 2
Developer
Milan Topalov

Why not just change the server settings to what the warning suggests (i.e. in PHP.ini set allow_url_fopen=1)?

Or if you don’t have access to php.ini, try adding “php_value allow_url_fopen On” line to .htaccess file in the root of your website.

Jean-Michel
# 3
Jean-Michel

Thanks Milan, the htaccess rule did the trick.

seeingis
# 4
seeingis

Worked from me. Used the .htaccess file method.  Thanks.