Extension, Plugin

Developer
Supported

In

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Causing Effect

     

You must be logged in to post.

In:sert inside in:clude outputting brackets, EE 2.9.3, In 1.2

General

Ryan Masuga
Ryan Masuga

We’ve successfully used In on a 2.9.3 install before, but on this particular install, it seems that putting in:serts inside an in:clude outputs the enclosing brackets. We just started a new branch on this project where this is happening.

Here is a pic of the mobile nav and site nav inserts that are inside a header in:clude: http://cloud.masugadesign.com/image/2P0i1c1F1j1y

This was working before (it’s working on the production site right now) but for some reason isn’t working in this case. If I convert the header in:clude back to an embed, the in:serts work as expected - but we’re trying to get away from embeds.

Any easy, low-hanging things to try? Re-install the add-on? Some config setting?

Causing Effect - Aaron Waldon
# 1
Developer
Causing Effect - Aaron Waldon

Hi Ryan!

I was unable to see the image in the cloud link you posted. It says the page could not be found.

I have not run into the extra braces issue before. Not sure why the braces would remain in the dev environment. Are there any pertinent differences in the different environments’ config settings?

nacnewmedia
# 2
nacnewmedia

little late to the party but I see the same thing here, EE 2.8.1 & latest CE In. My(cached) header:

{exp:ce_cache:escape}{exp:in:clude:includes/stylesheets}{/exp:ce_cache:escape} 

then inside that:

{exp:minimee:css
  attribute
:type="text/css"
  
attribute:rel="stylesheet"
  
attribute:media="all"
  
cachebust="v4-0"
 
}
  {in
:sert:includes/stylesheets_common}
 {
/exp:minimee:css} 

I get the curly braces being output to the page - funny part is this: removing the curly braces like so

in:sert:includes/stylesheets_common 

and it works as expected, outputs the template and no extra moustaches! thought I was taking crazy pills, Ryan - thanks lol