Plugin

Developer
Supported

Hacksaw

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Brett DeWoody

     

You must be logged in to post.

PHP Errors in EE 2.9.3

Bug Report

Geoff Towle
Geoff Towle

Hi Brett,

Do you have any insight on these errors? Thanks.

A PHP Error was encountered
Severity: 8192
Message: Non-static method Eehive_hacksaw::usage() should not be called statically, assuming $this from incompatible context
Filename: eehive_hacksaw/pi.eehive_hacksaw.php
Line Number: 11

...and…

A PHP Error was encountered
Severity: Warning
Message: Cannot modify header information - headers already sent by (output started at /code/biotherm-ee/manage/codeigniter/system/core/Exceptions.php:170)
Filename: core/Common.php
Line Number: 479

Geoff Towle
# 1
Geoff Towle

Brett,

Disregard. I just realized I was running PHP 5.6 on my local install, but the server is 5.4 and there aren’t any errors in 5.4. Thanks.

Geoff

Davor
# 2
Davor

You could update how usage() function is defined.. to

public static function usage() 

davor

Jonathan Schofield
# 3
Jonathan Schofield

Thanks, Davor. Worked for me :)

MarkS
# 4
MarkS

Worked for me too, cheers