Fieldtype

Developer
Supported

Expresso

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Image upload with multiple upload destinations [resolved]

General

adlur
adlur

So I’m following along with why an upload destination needs to be defined when creating an Expresso field- unfortunately something’s going wrong (I think.)

When I select the file button and the default file manager opens, I can upload my image to any of the existing upload destinations- it works fine, however the Expresso field is looking for the thumb in the destination that I defined when I added the field…

Here’s what I’ve got:

Within the file manager I have 4 upload destinations: “images”, “pdfs”, “videos”, “uploads”. When I defined the custom Expresso field in my field group I set the upload destination to “uploads”. So I’m publishing an entry, I click “File” which gives me the file manager, I select the upload destination I want (images), upload the image, all is well- there is an image and a thumb for it in my images directory, but the Expresso field is looking for it in the uploads directory…

PutYourLightsOn
# 1
Developer
PutYourLightsOn

just updated Expresso to version 1.2, please update and let me know if this solves the issue.

cherylrae7
# 2
cherylrae7

I am using 1.2 and this is a mess - really….

I’ve found an inconsistency in Expresso- when I created the field
“content” I defined “uploads” as the directory associated with it (you have to
define a single upload destination). If you attempt to upload an image into any
of the other directories (“images”, “PDFs” etc.) it breaks…

breaks is an understatement…
help!!

adlur
# 3
adlur

Just uploaded 1.2, the CP says 1.1.1 but I checked the file and it says 1.2. Still the same behavior, choosing an existing image works fine (whatever the directory). It’s the developer version, if that’s important-

cherylrae7
# 4
cherylrae7

mine is developer too… please help!

PutYourLightsOn
# 5
Developer
PutYourLightsOn

i’m not able to replicate this issue. in version 1.2 the upload destination is no longer selectable. instead, there is a Yes/No dropdown to indicate whether the file manager should be available. can you please confirm this is so on your end?

can you also please clarify what you mean by “breaks”? please feel free to email me screenshots that help to illustrate the problem you are having.

adlur
# 6
adlur

Version 1.2 is a dropdown yes/no, however now the image is given no path- so img tags are dropped in with just the file name, no directory… that goes for uploading a new image and choosing an existing-

PutYourLightsOn
# 7
Developer
PutYourLightsOn

ok please try the updated version 1.2.1, should work now

adlur
# 8
adlur

pretty sure that fixed it!