Fieldtype

Developer
Supported

Expresso

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

BUG REPORT

Bug Report

JKDesign
JKDesign

Hello, I just installed Expresso 5.3.1 Update and here is what i get when I try to install:

Fatal error: Uncaught Error: Call to a member function getAuthor() on null in /home4/zonethrp/public_html/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php:689 Stack trace: #0 [internal function]: EllisLab\ExpressionEngine\Controller\Addons\Addons->install(Array) #1 /home4/zonethrp/public_html/system/ee/EllisLab/ExpressionEngine/Core/Core.php(241): call_user_func_array(Array, Array) #2 /home4/zonethrp/public_html/system/ee/EllisLab/ExpressionEngine/Core/Core.php(110): EllisLab\ExpressionEngine\Core\Core->runController(Array) #3 /home4/zonethrp/public_html/system/ee/EllisLab/ExpressionEngine/Boot/boot.php(151): EllisLab\ExpressionEngine\Core\Core->run(Object(EllisLab\ExpressionEngine\Core\Request)) #4 /home4/zonethrp/public_html/admin.php(153): require_once(’/home4/zonethrp…’) #5 {main} thrown in /home4/zonethrp/public_html/system/ee/EllisLab/ExpressionEngine/Controller/Addons/Addons.php on line 689

JKDesign
# 1
JKDesign

Please help!

JKDesign
# 2
JKDesign

And when I go to the website the screen says:

Warning
require(user/addons/expresso/settings.php): failed to open stream: No such file or directory
user/addons/expresso old/ft.expresso.php, line 31

Severity: E_WARNING
Warning
require(user/addons/expresso/settings.php): failed to open stream: No such file or directory
user/addons/expresso old/ft.expresso.php, line 31

Severity: E_WARNING

Fatal error: require(): Failed opening required ‘/home4/zonethrp/public_html/system/user/addons/expresso/settings.php’ (include_path=’.:/opt/cpanel/ea-php73/root/usr/share/pear’) in /home4/zonethrp/public_html/system/user/addons/expresso old/ft.expresso.php on line 31

PutYourLightsOn
# 3
Developer
PutYourLightsOn

What version of ExpressionEngine are you currently running?

The second set of errors suggest that the add-on files are in the wrong directory:

user/addons/expresso old/ft.expresso.php 

Can you double check that the latest versions of the add-on files were correctly copied over?