Fieldtype

Developer
Supported

Expresso

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Problem with latin and other entities

Support (Resolved)

netfocus
netfocus

Hi,

Before I used Wygwam Editor and there was a built-in feature in the add-on for disabling Latin and other entities.

I switched to Expresso because it’s overall feature and compatibility seems best overall.

But now I am struggling with the fact that I can’t disable the entities even if I change the config file in the Theme folder like this :

CKEDITOR.editorConfig = function( config ) {
config.entities = false;
        entities: false,
        basicEntities: false,
        entities_greek: false,
        entities_latin: false,
};

It should d work but it is not! Is there something I’m doing wrong?

It is important for me because the EE search engine does’t find Latin entities and the site language is french.

It means the search engine will not find any word that contain Latin entities.

So I will really appreciate some help here.

Thanks!

netfocus
# 1
netfocus

I use this code :

CKEDITOR.editorConfig = function( config ) {
        config.entities: false,
        config.basicEntities: false,
        config.entities_greek: false,
        config.entities_latin: false,
};

PutYourLightsOn
# 2
Developer
PutYourLightsOn

You’ll need to add the new config settings to the defaults array in /themes/user/expresso/javascript/expresso.js, so for example:

var defaults =
{
   entities
false

Let me know if that works for you.
Ben

netfocus
# 3
netfocus

Seems to work now.

Thanks!

PutYourLightsOn
# 4
Developer
PutYourLightsOn

Glad to hear it!