Fieldtype

Developer
Supported

Expresso

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Error on install

Support (Resolved)

fensterbaby
fensterbaby

Just installed Exprresso 5.0.1

Got the following error:

Parse error: syntax error, unexpected ‘?’ in /home/aktest2/public_html/system/user/addons/expresso/ft.expresso.php on line 123

PutYourLightsOn
# 1
Developer
PutYourLightsOn

This is due to a PHP7 feature that was being used, fixed in Expresso 5.0.2.

fensterbaby
# 2
fensterbaby

deleted 5.0.1 and installed 5.0.2

Error persists

Parse error: syntax error, unexpected ‘?’ in /home/aktest2/public_html/system/user/addons/expresso/ft.expresso.php on line 123

PutYourLightsOn
# 3
Developer
PutYourLightsOn

This is a duplicate of the following thread, can you please follow there? There is also a temporary fix to get it working until we have an update. Sorry about the blunder.
https://devot-ee.com/add-ons/support/expresso/viewthread/16515

fensterbaby
# 4
fensterbaby

I upgraded to a more recent php version and it’s good now.

thanks!

PutYourLightsOn
# 5
Developer
PutYourLightsOn

Ok great, PHP7 will make your site run faster anyway :)