Fieldtype

Developer
Supported

Expresso

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Receiving Multiple Warnings Regarding Expresso

Support (Resolved)

allgood2
allgood2

We’ve just moved servers and upgraded to PHP7, so I’ve been going through a client’s site with errors on high, to fix as much as possible. Both from the Control Panel and the frontend I get a series of three Expresso related errors:

Declaration of Expresso_ft::replace_tag($data$params = Array) should be compatible with EE_Fieldtype::replace_tag($data$params = Array, $tagdata false)

Declaration of Expresso_ft::save_settings() should be compatible with EE_Fieldtype::save_settings($data)

MessageCannot modify header information headers already sent by (output started at /server-path/system/codeigniter/system/core/Exceptions.php:170)
Filenamecore/Common.php
Line Number
479 

Is there anything that can be done to fix them. The clients running EE 2.11.9 with Expresso 3.4.8

 

PutYourLightsOn
# 1
Developer
PutYourLightsOn

Update to the latest version of Expresso (currently 4.2.4) and you won’t see those errors.

allgood2
# 2
allgood2

The site is running EE 2.11.9 since it uses Expresso Store which is still not compatible with EE 3.x. Does Expresso 4.2.4 work with it. The version I downloaded only seem to be available for EE3.x?

allgood2
# 3
allgood2

I went back to check. While it says EE 4.2.4 is available for EE2 & 3, the download only came with one installer for EE3, and when I installed I believe there were a lot more errors, so I uninstalled and grabbed the legacy file.

PutYourLightsOn
# 4
Developer
PutYourLightsOn

We have updated the legacy version of Expresso to 3.5.0 which should fix these PHP errors for you. Please let us know if you have any further issues.