Fieldtype

Developer
Supported

Expresso

ExpressionEngine 2, ExpressionEngine 3, ExpressionEngine 4, ExpressionEngine 5

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

1 of 2
1
   

You must be logged in to post.

Where is the File Manager? [resolved]

General

supermonix
supermonix

Hi! First of all, thank you for your great work!

I installed Expresso and set File Manager YES in the Custom Field screen, but there is no File Manager button in the Publish area. What can be wrong?

I read about an upload directory, but I cannot find where to set it up. But maybe in my version 1.2.2 is not necessary. Anyway, I can’t upload images nor docs.

Thanks a lot for help me!
Monica

supermonix
# 1
supermonix

Attached 2 screenshots.

Thanks.

PutYourLightsOn
# 2
Developer
PutYourLightsOn

have you defined an upload destination in the cms?

supermonix
# 3
supermonix

yes, I have

PutYourLightsOn
# 4
Developer
PutYourLightsOn

ah it is issue with your language settings. can you please try changing “Link” to whatever that is in your language in ft.expresso.php on line 117:

var button = $(”#cke_’.$this->field_name.’ span.cke_button a[title=Link]”).parent();

i’ll be sure to fix this in the next release.

supermonix
# 5
supermonix

sorry, but I don’t understand…

what does it mean “in your language”? My EE installation is in English.

supermonix
# 6
supermonix

Ah! ok, I understand.
Just a minute. I’m going to try! :)

supermonix
# 7
supermonix

No :( not working…
I tried collegamento, file, documento… not working

PutYourLightsOn
# 8
Developer
PutYourLightsOn

hover over the link icon and you should see it

supermonix
# 9
supermonix

Hi! I found the problem. I had Firefox in italian. Using Firefox in english it works.
Anyway, this is a problem for me, because my clients usually use the browser localized in italian.
Could you fix it someway?

Thank a lot! :))

PutYourLightsOn
# 10
Developer
PutYourLightsOn

please change line 117 in ft.expresso.php to:

var button = $(”#cke_’.$this->field_name.’ span.cke_button a.cke_button_link”).parent();

supermonix
# 11
supermonix

Great!! It works.
Thank you very much :)

PutYourLightsOn
# 12
Developer
PutYourLightsOn

glad to help. please leave a review for the add-on if you have time.

Moly Yim
# 13
Moly Yim

Hello,

I can’t seem to get the File Manager to show up either, and I’ve already set an upload destination and have tried changing that line (didn’t work). Any ideas?

PutYourLightsOn
# 14
Developer
PutYourLightsOn

is your browser language english? did you select Yes from the file manager dropdown in Expresso’s field settings?

Moly Yim
# 15
Moly Yim

Yes and yes to both questions.

1 of 2
1