Extension, Fieldtype

Developer
Supported

EEvent Helper

ExpressionEngine 1.x, ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Derek Hogue

     

You must be logged in to post.

Error with EE 2.10.1 unable to clone and set expiring date

Bug (Resolved)

Barbara Cinotti
Barbara Cinotti

Hi Derek,

I’ve upgraded from EE 2.9.2 to EE to v2.10.1 - Build Date: 20150501.

I’ve 2 fields for start date and end date.
I set Clone custom Start Date to Entry Date? YES
Set times to midnight? YES
Set Expiration Date to 23:59? YES

When i create an entry I received an error for both entry date and expiration date “The date you submitted is not valid.”
The entry date field remains with the entry date and seems that it’s not able to clone the start date in it, and the expiry field is empty it seems that it can write in it.

Do you have any suggestions?

Thanks

Barbara

Derek Hogue
# 1
Developer
Derek Hogue

Are you using EEvent Helper 2.2.2? I released an update at the end of March which fixed issues with EE 2.10.

If you’re using the current version and still having trouble, can you tell me if changing your date formatting preference affects the outcome?

Barbara Cinotti
# 2
Barbara Cinotti

Hi Derek,

yes sure it’s Event helper 2.2.2

I’ve tested the Localization settings in the user setting profile and I noticed that if I change the Date Formatting all types work except the format dd/mm/yyyy.

With the “/” it doesn’t work with “-” it works,

Hope it’s help

Barbara

Derek Hogue
# 3
Developer
Derek Hogue

Thanks for narrowing this down Barbara. I just tested my local install of EE 2.10.1 and EH 2.2.2 using dd/mm/yyyy and it worked as expected, with both EEvent Helper date fields and native EE date fields.

If you’re able to and comfortable doing so, would you be willing to email me an admin login for your site so I could investigate further? derek@amphibian.info

Barbara Cinotti
# 4
Barbara Cinotti

Yes sure!
thanks

Derek Hogue
# 5
Developer
Derek Hogue

This issue was resolved with Event Helper 2.2.3.

Delaris Dev
# 6
Delaris Dev

I’m having this issue after upgrading EE from 2.9.3 to 2.10.3.  I’m using EEvent Helper version 2.2.6

Derek Hogue
# 7
Developer
Derek Hogue

Delaris Dev - can you elaborate? Are you getting the same error Barbara mentions above (“The date you submitted is not valid”)? What is your current date format in the control panel?

Delaris Dev
# 8
Delaris Dev

I get the same error, but on the set and expire fields I get the date I entered but the years are 2020 instead of 2016.  On the Date tab for the entry it puts dates of 12/13/1901 for both the entry and expiration date.

I had the entry format a mm/dd/yyyy.

After changing to mm-dd-yyyy it works.

Derek Hogue
# 9
Developer
Derek Hogue

Very weird, I can’t replicate this. If you email me a Super Admin login I can have a look. derek@amphibian.info

Delaris Dev
# 10
Delaris Dev

I can’t even replicate it now.  I think it has something to do with my EE installation because now the changes that I make to the date format in the localization setting aren’t applied. 

I’ll figure it out.  Thanks for your quick response.