Module

Developer
Supported

EEasy Capture

ExpressionEngine 2, ExpressionEngine 3

Back to this add-on's main page
View Other Add-ons From MK Labs

     

You must be logged in to post.

EE4 compatible

General

stefanos
stefanos

Dear Mklabs team,

Does EEasy Capture is compatible with EE4, or need to be updated ?

regards

Stéphane

stefanos
# 1
stefanos

EE3 soon will not yet supported,

Does EEasy Capture is compatible with EE4, or need to be updated ?

stefanos
# 2
stefanos

EEasy Capture is not compatible with EE4.
The more recurrent error :

Methods with the same name as their class will not be constructors in a future version of PHP; Eeasy_capture_upd has a deprecated constructor

When EEasy Capture and all your other add-ons will be updated to EE4?

stefanos
# 3
stefanos

It’s a PHP version problem. When PHP > 5.6 (7.xx) this message error appears. Could you update the code please?

stefanos
# 4
stefanos

​​php Only variables should be assigned by reference solution:

All the line code with this error message will be modified (removing &) :

$this->EE =& get_instance(); 
to
$this
->EE get_instance(); 

 

php Only variables should be assigned by reference

From the PHP manual : https://secure.php.net/manual/en/language.oop5.decon.php :

Warning Old style constructors are DEPRECATED in PHP 7.0, and will be removed in a future version. You should always use __construct() in new code.

The Class and the function could not have the same name.

class Eeasy_capture {}

function Eeasy_capture_mcp() to function __construct() 


All the error lines deprecated code was modified, so, mo more message error (in the Control Panel, and in the result web page)

 

 

stefanos
# 5
stefanos

No more support ??