Accessory

Developer
Supported

Developer

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

Deprecated function call with EE 2.8

General (Resolved)

Lima Bean
Lima Bean

Deprecated function add_to_head() called in C:\wamp\www\project\system\expressionengine\third_party\developer\acc.developer.php on line 339.
Deprecated since 2.8. Use CP::add_to_foot() for scripts instead.

PutYourLightsOn
# 1
Developer
PutYourLightsOn

thanks, it’s not a bug but i’ll update in a future release

PutYourLightsOn
# 2
Developer
PutYourLightsOn

Just an update on this: since Developer is using javascript to inject HTML into the DOM, and that HTML needs javascript events attached to it (for the dropdown menus) which is run by EE before the add_to_foot() hook is called, it can’t be done in the footer as the EE Developer Log notice would suggest.