Plugin

Developer
Supported

Delete entries and comments

ExpressionEngine 1.x, ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Milo Creative

     

You must be logged in to post.

clicking delete link doesn’t delete.

General

CreateSean
CreateSean

Milo,

I’ve got this set up, but every time I click the delete comment link I get the message “It seems that this comment has been already deleted” I’m not sure what I’m doing wrong as I’ve read and re-read and re-read the docs and triple checked everything.

my template code where the comments reside

{exp:delete:link
id
="{comment_id}"
type="image"
template="blog/delete_comments"
alert="false"
}
Delete Comment
{
/exp:delete:link} 

and the blog/delete_comments code

{exp:delete:delete_comment 
comment_id
="{comment_id}" 
error_no_permissions="You're not allowed to delete this comment"
error_invalid_content="It seems that this comment has been already deleted"
message_success="Comment deleted!" 
Milo Creative
# 1
Developer
Milo Creative

Have you tried to use {segment_3} instead of {comment_id} in blog/delete_comments?

The delete:link tag creates a link that looks like this:

<a href="http://blabla.com/blog/delete_comments/1234">Delete Comment</a

...where 1234 is the value of the id attribute.

In the delete:delete_comment tag you need to pass that 1234 to the comment_id attribute:

{exp:delete:delete_comment 
comment_id
="{segment_3}" 
error_no_permissions="You're not allowed to delete this comment"
error_invalid_content="It seems that this comment has been already deleted"
message_success="Comment deleted!" 
romanovsky2007
# 2
romanovsky2007

hi Milo,

i have the same problem, but changing to {segment_3} won’t help in my case.. what else can be wrong?

dmitry

Milo Creative
# 3
Developer
Milo Creative

Dmitry can you post snippets of code from your templates?

pilgrimish
# 4
pilgrimish

@dmitry, @milocreative, @createsean - did you ever resolve this? I’m having the same problem, but with entries instead of comments.