Plugin

Developer
Supported

CE Image

ExpressionEngine 1.x, ExpressionEngine 2, ExpressionEngine 3

Back to this add-on's main page
View Other Add-ons From Causing Effect

     

You must be logged in to post.

images will not resize since GZIP compression was enabled

Support Request

eastwooddesign
eastwooddesign

My images will not resize since GZIP compression was enabled on my server.

I can I have gzip enabled on the server and still use CE Image?  When I try and use CE code I get a 500 error

{exp:ce_img:single src=”{your_custom_field}” width=“500”}
or
{exp:ce_img:single src=”/images/imagelfile.jpg” width=“500”}

if I use

{exp:ce_img:single src=“http://3rdpartydomain.com/images/image.jpg” width=“500”} no code is returned but the page loads

 

Causing Effect - Aaron Waldon
# 1
Developer
Causing Effect - Aaron Waldon

Hi eastwooddesign!

Not sure why you are getting an error, but I recommend that you do not gzip using EE. You can disable gzipping in the control panel or from the config:

$config['gzip_output''n'

Error pages throw 500 errors when EE’s gzip setting is on. I’ve found that enabling gzip through htaccess or the nginx config seem to be a much better way to go, and tends to be very easy to do. Here’s a quick guide I just found in a Google search: https://varvy.com/pagespeed/enable-compression.html