Extension, Module

Developer
Supported

CE Cache

ExpressionEngine 2, ExpressionEngine 3

Back to this add-on's main page
View Other Add-ons From Causing Effect

     

You must be logged in to post.

Weird homepage caching issue driving us crazy

Support Request

rfsupport
rfsupport

Hi all,

We have a weird issue with our CE Cache setup. We’re running the following environment:

ServerLinux
Web Server
Apache 2.4
PHP version
5.5.9-1ubuntu4.27
EE version
v2.10.1
CE Cache version
1.10.1 

Our caching works fine for all pages except the home page. We are using the htaccess rules from here:

https://docs.causingeffect.com/expressionengine/ce-cache/user-guide/static.html#installation-step-3 

With some troubleshooting I found that the DirectoryIndex parameter makes a difference. If we set the following:

DirectoryIndex index.html 

Caching for ALL pages (including home page!) works fine. However, if we delete the cache, the home page gives a forbidden error (i.e. no longer talks to ExpressionEngine, presumably because index.php isn’t being called). Oddly it seems that non-homepage pages still regenerate their pages.

If we change it to the following:

DirectoryIndex index.html index.php 

Caching for ALL pages EXCEPT the homepage works fine, with the homepage going direct to ExpressionEngine.

We’ve spent a ton of time on this issue, and we’re at a loss as to why its behaving like this.

As an aside, we’ve found that within the EE Admin, if we try to browse individual cache pages, we get the following error:

An unexpected response was received:

error 

Not sure if it’s related at all, but thought I’d include it. Deleting the entire cache still works - we just can’t browse individual cache pages via the UI.

Thanks!
Kyle

 

Causing Effect - Aaron Waldon
# 1
Developer
Causing Effect - Aaron Waldon

Hi rfsupport!

It’s difficult for me to guess what could be going awry. I would need to actively see the debug information and the Apache or nginx config and make sure everything is set up properly.

This reminds me of a similar post from long ago: https://devot-ee.com/add-ons/support/ce-cache/viewthread/13629

Does that old thread help at all?

rfsupport
# 2
rfsupport

Thanks Aaron. I looked through that thread but didn’t see anything that could help here - looks like the OP on that thread didn’t respond back with their final solution either. I can provide additional details, though here are the highlights:

1) PHP configuration is default
2) Apache configuration does not have anything out of the ordinary. The only somewhat different setting is that we have the following options enabled:

CheckSpelling On
CheckCaseOnly On 

If you can let me know what else you’d like to see, or try, I’ll try to provide it!

Thanks!
Kyle

 

Causing Effect - Aaron Waldon
# 3
Developer
Causing Effect - Aaron Waldon

Hi Kyle!

I would not be able to guess why this isn’t working in that particular environment. If you’d like to set up a dev server where you can replicate the issue and send me an email with credentials, I’d be happy to take a look. If you’d like to go that route, please email me at software at causingeffect dot com

Regards,

Aaron