Extension, Module

Developer
Supported

CE Cache

ExpressionEngine 2, ExpressionEngine 3

Back to this add-on's main page
View Other Add-ons From Causing Effect

     

You must be logged in to post.

Problem installing

Support (Resolved)

Della Nesta
Della Nesta

Hi, when i try to install ce cache it returns this error and the add on not work properly?

Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes:
CREATE TABLE `exp_ce_cache_db_driver` ( `id` VARCHAR(250) NOT NULL, `ttl` INT(10) NOT NULL DEFAULT ‘360’, `made` INT(10), `content` LONGTEXT, PRIMARY KEY `id` (`id`) ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE=InnoDB;

Can you help me to resolve thi sproblem?

Thank you

Causing Effect - Aaron Waldon
# 1
Developer
Causing Effect - Aaron Waldon

Hi Della!

I believe this happens in new installs that use multibyte database encoding. I have a new version of CE Cache for you to try out if you’d like. Please send me an email me (software at causingeffect dot com) along with your license key.

Thanks,

Aaron

kyq
# 2
kyq

Hi Aaron,
I am getting the same error after installing:
SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes:
CREATE TABLE `exp_ce_cache_db_driver` ( `id` VARCHAR(250) NOT NULL, `ttl` INT(10) NOT NULL DEFAULT ‘360’, `made` INT(10), `content` LONGTEXT, PRIMARY KEY `id` (`id`) ) DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci ENGINE=InnoDB;

Could you send me the update, too?

*Update:* Resolved over email - Aaron