Fieldtype

Developer
Supported

Catchall

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Vector Media Group

     

You must be logged in to post.

PHP error after upgrade to EE 2.2

General

artmem
artmem

After upgrading to EE 2.2, I get the following error on my publish and edit screens when there is a catchall field present:

A PHP Error was encountered
Severity: Notice
Message: Undefined index: field_visibility
Filename: content/publish.php
Line Number: 70  

A PHP Error was encountered
Severity: Notice
Message: Undefined index: field_visibility
Filename: content/publish.php
Line Number: 71

Rob Sanchez
# 1
Rob Sanchez

Can you try going to edit the settings for that field, and just re-saving those settings, and see if that fixes anything?

artmem
# 2
artmem

That didn’t seem to do anything.

Rob Sanchez
# 3
Rob Sanchez

I don’t know what field_visibility is, there’s nothing in the Catchall fieldtype that use that. So it sounds like an EE thing? Maybe a corrupted publish layout?

artmem
# 4
artmem

Thanks. There is something going on with the publish layout—the error shows up in the middle of the publish sidebar and breaks its layout. I’ve posted about this on the EE forums, too, but they suggested I post here too, since it only happens when there is a catchall field present.

Rob Sanchez
# 5
Rob Sanchez

Maybe try re-saving your layout.

artmem
# 6
artmem

Re-saving the layout didn’t do anything, but resetting it fixed the problem. Thanks!