Extension

Developer
Supported

BiopsEE

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Digital Surgeons

     

You must be logged in to post.

Fatal Error 0.9.1 beta

Support Request

CheifWiggam
CheifWiggam

Just bought/installed the module and greeted with:

Fatal errorfunc_get_args(): Can't be used as a function parameter in /custom_system_folder/expressionengine/third_party/biopsee/libraries/Biopsee_template.php on line 161 

Fairly vanilla 2.5.5 EE install, a few standard type modules (P+T, solspace) everything else is working.

dstechroom
# 1
Developer
dstechroom

Hi CheifWiggam,

What version of php are you using, and with what error_reporting level? We suspect this might have something to do with E_Strict being on.

dstechroom
# 2
Developer
dstechroom

Turns out this looks like an error to do with php versions less than 5.3.0.  We haven’t explored php 5.2 compatibility yet, explaining why we didn’t catch this before.  We are sending you a zip file of a development version to try out.  Check for it at the email you use to purchase through Devot:ee.

CheifWiggam
# 3
CheifWiggam

Thanks for that, you are correct, the server is running 5.2.17. The dev version still errors in dramatic fashion, so have disabled for now. I’m 3rd party contractor for this project so changing PHP wont happen anytime.

Hit me back if you back date support to 5.2 :)