Fieldtype

Developer
Supported

ALT MultiField

ExpressionEngine 2

Back to this add-on's main page
View Other Add-ons From Utilitarienne

     

You must be logged in to post.

Error in EE2.8.1

Support Request

pumpinteractive
pumpinteractive

Plugin generates the following error when viewing the live site or attempting to access a field set to ALT Multifield:

Fatal error: Call to undefined method EE_Fieldtype::EE_Fieldtype() in /Library/Server/Web/Data/Sites/*sitenameremoved*/system/expressionengine/third_party/alt_multifield/ft.alt_multifield.php on line 37

Adrienne Travis
# 1
Developer
Adrienne Travis

Yeah, this doesn’t surprise me—EE made a ton of breaking changes in 2.8 and I haven’t had any chance to screw with it yet. I have a batch of improvements I’m trying to get ready for release, I’ll see if I can sort this out along with those.

pumpinteractive
# 2
pumpinteractive

Updating EE is never a robust process unfortunately. Thanks for the quick response. Looking forward to the new version, if you know a quick fix/patch for this issue you could pass to me it would be much appreciated.

Cheers.

pumpinteractive
# 3
pumpinteractive

As a note, replacing line 37 in ft.alt_multifield:

parent::EE_Fieldtype(); 

with

parent::__construct(); 

Resolves the error and appears to make the plugin work correctly, although I have’t tested it heavily yet.