Module

Developer
Supported

EE 1
EE 2
FireMail

Back to this add-on's main page
View Other Add-ons From PutYourLightsOn

     

You must be logged in to post.

email link being broken

Support (Resolved)

Mark Peach
Mark Peach

My client is using firemail to send out newsletters. And we have hit an issue.

The email body is created purely from a template - and all my client does is to import the template and then email out.

Within their email body they have put in a link that is href=“mailto:someone@mydomain.com” so respondents can respond on this particular item. My client added this link by editing with Wygwam editor I use when they publish the original entry picked up by the template.

Firemail is encoding the link as per other links and hence breaking it as a mailto link. It does not seem to recognise mailto:

Is there any way to stop it encoding a particular link like mailto:

I have been able to fix it by going into the firemail editor and going to source and fixing the link there. But a save buttom would help here rather than having to mail it out.

Ben @PutYourLightsOn
# 1
Developer
Ben @PutYourLightsOn

hi mark, FireMail should not encode mailto links. can you paste the exact code of the link here for me to see?

Mark Peach
# 2
Mark Peach

Hi, Thank you for the response - this is the HTML of the entry

This can be arranged via a <a href="mailto:cbailey@hotmail.com?subject=Consultation">nutritional consultation</a> and dietary changes and supplements can be recommended to help lower your levels

and this becomes when the template is rendered by firemail

This can be arranged via a <a href="http://www.advancen.co.uk/index.php?URL=mailto:cbailey@hotmail.com?subject=Consultation">nutritional consultation</a> and dietary changes and supplements can be recommended to help lower your levels

Please note I have cut and pasted the above from the entry html (wygwam) and generated code - but then edited the email addr and website URL above to disguise the real email address and website address.

 

 

 

 

Mark Peach
# 3
Mark Peach

Do not want to confuse the issue - but just noticed another devot-ee support call you are dealing with regarding link redirection - looks like my issue is also an overlap. On the none mailto: links I am getting a redirect page appearing when clicking on a link - in fact I reported this yesterday on the EE technical support forum http://expressionengine.com/forums/viewthread/208055/
(ps normally I do not work on Sundays - I try not to be that sad - but my client was desperate to get their email out )

I was assuming firemail was converting links to add index.php?URL= for tracking purposes - is this the case or is EE doing this and is they a way to immediately redirect rather than have the immediate page?

 

Ben @PutYourLightsOn
# 4
Developer
Ben @PutYourLightsOn

mark, what version of EE and FireMail are you on?

Mark Peach
# 5
Mark Peach

Hi

EE Version 2.3.1 Build 20111017

Firemail 1.7.4

Ben @PutYourLightsOn
# 6
Developer
Ben @PutYourLightsOn

thanks, i’ll look into it further and let you know what i find.

Ben @PutYourLightsOn
# 7
Developer
Ben @PutYourLightsOn

this has been fixed in version 1.8