Extension, Module

Archived
Forum
(read-only)

mithra62 does not actively monitor this forum
(but you can still get help from other EE users).


For official support, visit the official support site »

EE 1
EE 2
Backup Pro

Back to this add-on's main page
View Other Add-ons From mithra62

     

You must be logged in to post.

Passwords for ZIP’s, Assuming Corruption…

Support (Resolved)

Mitchell
Mitchell

Just picked up BackupPro due to the reviews and have ran into an issue.  I’m backing up the DB and “Files” and the process goes through however when I download the “Files” zip file it asks for a password. 

I’m not sure what the password is? 

Which is leading me to think the file is corrupted.  I pulled it both out of the backup folder and through the CP with the same results.

I am running BackupPro from outside the webroot where my system folder is.  I don’t have this issue with the DB download and I am using 1.8.3.

Any ideas or suggestions?

mithra62
# 1
Developer
mithra62

Hi Mitchell,

Sorry to hear about your issue; you’re right that the Zip files shouldn’t be asking for a password.

It sounds like Backup Pro may be timing out or running out of memory. Depending on the amount of files to backup the process can take a considerable amount of time and if some of those files are quite large you could run into memory limitations within PHP. Can you try excluding any large files for a quick test (you can set that under Settings) and run the file backup again? If it finishes and extracts fine I’d say the cause would be found and increasing the time and memory limits would fix you right up.

If not (or if you’re not comfortable doing the above), could you send over FTP and CP access to the below email so I can take a look and debug things for you?

Thanks,
Eric
eric at mithra62 dot com

mithra62
# 2
Developer
mithra62

Hi Mitchell,

I’m just checking in to see if you were able to work it out or still need assistance. Let me know if I can help.

Thanks,
Eric

Mitchell
# 3
Mitchell

Turns out my third-party folder was “clogging” the backup.  I put all the folders in individually and now it works fine. 

Might be nice if there was an option to backup EE’s original file listing (like the folder structure you originally download in the zip file from ExpressionEngine.com) or have the ability to exclude a folder from being backed up versus having to list them all out and excluding just the one.  Just a thought.

(I might also be purchasing the developer version depending on if my cron job works tomorrow.  Is there a refund / discount process since I just bought the addon today?)

Thanks also for the quick response.  Take care.

mithra62
# 4
Developer
mithra62

Hi Mitchell,

Good to hear you worked it out. That’s an interesting suggestion; I’ll take it under advisement.

If you decide to go with the Developer license simply return Backup Pro through Devot:ee and you should be set. Ryan has gone to great pains to make returns very easy for users so there’s a whole automated process from within your account page to walk you through. Please let me know if you have issues though and I’ll work with Ryan to get it done.

Thanks,
Eric